About

All telecom fundamentals on SIP protocol, VOIP, RTP, RTCP knowledge, Technical Youtube Videos, Linux material, Android, SSCA certification information,the sip school videos.

Sunday, 30 September 2012

Fixing Android Tablet Not Booting A Personal Experience With Chinese Tablet

Introduction
I am writing this tutorial as a personal experience with my chinese-made tablet pc. In general it is a 7" MID ePad Android Tablet powered by VIA 8650 800MHz CPU and Android 2.2 Froyo operating system. I believe the built in operating system is supplied by WonderMedia Technologies (WMT) as there are many WonderMedia Technologies applications pre-installed in it and some of them come with chinese user interface which i cannot understand and decide to uninstall later.
I decided to buy this chinese tablet because it was very affordable compared to other currently famous tablet pc such as Apple iPad, Samsung Galaxy Tab and Dell Streak, which price may be 4-5 times higher. And this was also my first time making purchase from overseas which i supposed to be quite risky. But considering the price was cheap (under $100) and if any bad things happened (cheating seller, broken in shipment, undelivered and etc) i just lost some bucks so i finally decided that it was worth to try and i will take the risk.
First Encounter
The parcel was delivered in about 10 days by UPS ExpressSaver which I had chosen when making the purchase. When the courier arrived at my home, I was asked to pay the import duty fee charged by customs and it cost me about $28. But later, after analyzing the import duty payment form, I found out that the handling fee charged by UPS itself cost more than the customs..!! Though I was disappointed, still I was very happy to receive this long awaited tablet pc in good condition. It was well packed in a carton box, wrapped with bubble form and put in a plastic UPS polybag.
I cant wait to open the package and turn on my tablet for the first time. It was a very happy moment like the moment when Archimedes cried out "Eureka!!". The android 2.2 froyo operating system started with an animation of android robot dancing and flying on the center of the screen then booted successfully to the home screen (in Windows we call it Desktop). The next few weeks after I received my tablet pc, I found myself playing games, typing emails, browsing sites, using facebook, playing multimedia contents and installing lots of applications with this chinese tablet pc. To add new android applications to this tablet, you cannot use the regular android app market such as found in Samsung GalaxyTab because it needs a registered google account with the android OS. I think that this chinese tablet is not supplied with legal, registered Android OS. The only way to install android applications to this chinese tablet pc is by downloading .apk extension files from internet, put them in your SD card and install them with the built-in file browser pointed to that SD card. Apk extension stands for Android Package and it is the installer file you need to add application to your chinese tablet pc, idem to msi extension in Windows OS. Running the apk files will install the application. Some places to download APK (android installer) files are:
http://www.freewarelovers.com/android
http://www.freeandroidware.com/
http://www.androiddownloadz.com/
http://www.android-apk.info/
Nightmare: Tablet Not Booting  

There was a night when my gf played angry birds in my chinese tablet pc and the next morning when I turned it on, it quitted booting and the screen froze with the android robot stood still in the center of the screen while on the left bottom corner of the screen showed: Android TM OS 2.2
Kernel 2.6.32
Build Number V1.3.1

Android Tablet Freeze on Booting Process

Trial I: Unsuccessful
I had tried a lot of ways to make it boot again including hard power off (pressing the power button for more than 5 seconds), reset the device (pushing a small pin to the small hole at the side of the screen, there are 2 holes: one for microphone and the other for reset button, you should try which one), leave it turned on until the battery drained off (just like pulling a bios battery off a motherboard to reset), try to press combinations of various keys I can find on the tablet pc. They all failed to fix this chinese tablet pc and made me start thinking that all chinese products are lack of quality. I searched google and read a lot of forum posts but find no solutions to my problem. I also tried to upgrade the firmware by copying new firmware to \script\ folder on the root of my SD card and put the SD card in its slot before turning on the tablet pc. It failed too because the screen did not react nor show anything, just freezing on the first boot screen with the android robot posing still in the center of the screen. Since then I always hate that robot. It was a frustrated experience and I started to read from forum posts that it could be a problem with the dead NAND drive in the tablet or the overheating/overcharging battery which may cease working.
Trial II: Failed Too
I tried to contact the seller and asked for solution to my problem, hoping that I could fix it myself without sending it back the country where it came from because if I did that, I had to bear the two ways shipping costs as one of the warranty terms and frankly they were not cheap and the customs may charge me another import duty fee when the repaired package arrived at my doorway. Overall the shipping costs may cost me the same price as a new tablet pc.
The seller is good and very cooperative, one of their sales team, a woman, told me to try to upgrade the firmware and provided me with 3 links of the firmware archive files. The 3 files were part of a RAR file which were splitted. The links were hosted in a chinese file sharing site :
EP07-V2.2.part1.rar -
EP07-V2.2.part2.rar -
EP07-V2.2.part3.rar -
As instructed, I downloaded all the files and used WinRAR to extract all the firmware files to \script\ folder in my micro SD card (some people call it TransFlash). So if my micro SD was loaded to drive F:\ then all the firmware files were stored in F:\script folder. Then I removed my micro SD card from the card reader and put it in the tablet micro SD slot while the tablet is off. With the power adapter kept charging to ensure that no power failure during firmware upgrade process, I turned the tablet on, hoping to get a message or warning of the firmware upgrade process like the one described in one forum about the firmware upgrade process. The first frame I saw on screen was the standing still android robot again, but after a minute, the screen did not shift to other frame about warning nor message. Curious, I waited longer (20 minutes - 30 minutes) and there was still nothing on the screen. For me, it meant there was no hope for my tablet, it had totally died. I was very upset and threw it to a corner of my house. "Rubbish" I mumbled. Due to my busy activities at that time, I had almost forgotten it and did not even try to contact the seller again to tell her about the failure.
Trial III: SUCCESS
Two weeks later, I had been through the busy times and that time I tried to make another contact to the seller again. Another sales team (not the one who handled my case before) replied my message. She asked me about the type of tablet I purchased and offered to upgrade the firmware again, but this time with a different firmware, not the previous two files. She said that was a new firmware suitable for my chinese tablet. I did not believe her anymore and said that I had tried upgrading the firmware given by her coworkers before and it failed. I also told her that there might be a problem with the internal NAND drive or overheating battery or processor as all tablets are sealed with no air circulation for its internal electronic components.
She told me not to worry (but I actually DID..!!), and asked me if I wanted to try her suggestion first or sent the tablet back to them immediately. Considering the high two-way shipping costs plus another customs import fee, I finally made myself try her suggestion with the latest firmware. I downloaded it from a link she provided:
New Firmware:
Official FW M009s WM8650 Android2.2 7" xx.11.06(Mediafire) -
Alternative Link:
Official FW M009s WM8650 Android2.2 7" xx.11.06(Rapidshare) -
She also provided me with old firmware in case i need it :
7inch 8650 latest firmware part 1 2.zip
Root patch part 2 2.zip
I never used this old firmware, i used the new one.
After I successfully downloaded the new firmware (Official FW M009s WM8650 Android2.2 7" xx.11.06) and viewed the archive with WinRAR, I saw a different file structure compared to previous firmware:
\M009S_06.11
\M009S_06.11\FirmwareInstall\*.*
\M009S_06.11\wmt_scriptcmd
The first and second lines were folders, the last one was a file. I tried to view the content of "wmt_scriptcmd" in Notepad and found out that the content had a lot of line pointed to FirmwareInstall\*.* files. I made a summary that this "wmt_scriptcmd" was probably like "autorun.inf" file in Windows OS which directed execution to certain files in FirmwareInstall folder. There was no "script" folder anywhere in the archive, contrary to what I knew about the firmware upgrade process which involving "script" folder.
Next, I copied all the contents of M009S_06.11 folder to the root folder of my micro SD so they became:
F:\wmt_scriptmd
F:\FirmwareInstall\*.*
Then I removed the micro SD from card reader and inserted it in the tablet micro SD slot. For safety and to make sure there was no battery failure during the firmware upgrade process, I plugged in the power adapter. After that I turned on the device and as usual, the android robot showed up. I did not expect this, but maybe the robot knew I hated it, this time it was just awhile and the screen shifted to next message showing the upgrade process. "Eureka..!!" I finally can upgrade the firmware, but still I did not know what would happen next, would the firmware upgrade process fail in the middle? and if the upgrade was successful, would it fix my tablet ? Here is the screenshot of the firmware upgrade process:
Android Firmware Upgrading Process
Here is the documented android firmware upgrade process step by step, as shown on the screen:
Upgrading W-Load to SF.
Upgrading U-Boot to SF.
Upgrading U-Boot env.cfg. to SF.
Upgrading Ramdisk to NAND.
Upgrading Kernel to NAND.
Upgrading FileSystem partition(Nand).
   Res_WmtLauncher.tgz
   Res_WmtPhoto.tgz
   Res_Wmtweather.tgz
   WM8650_dsp_R1.01.11.tgz
   WM8650_dsp_copybit_R1.0.3.tgz
   android2.2-froyo.tgz
   busybox-1.16.0.mvl5_v5t.tgz
   mtd_utils_mvl5_v5t.tgz
   copy rootfs patch&restore files...
Upgrading U-Boot LOGO to NAND
Upgrading Kernel LOGO to NAND
copy data to Android-Data partition(Nand)..
copy pre-files to LocalDisk...

On top of the screen there is a message "WM8650 Android2.2 FW Upgrading ..." while on the bottom of the screen there is a progress bar and a message "DON'T REMOVE INSTALLATION MEDIA" which changes to "PLEASE REMOVE INSTALLATION MEDIA" after successful upgrade.
If you are interested to see the video of the firmware upgrade process, i have successfully documented it here:

The upgrade process was quite fast, it just took less than 4 minutes to finish. After the process finished, the screen displayed a message to remove the micro SD and restart the tablet. After restarting the tablet, here came again the android robot, but it was just standing for a while and then proceeded to dance on the center of the screen. I was really happy to find out that this android robot had eventually come to life again after 2 months of inactivity. What an experience.. I believe that there are still a lot of people out there who may have the same problem like mine, frustrated with unbootable chinese tablet device. I personally hope this article will save your time, effort and money to fix your unbootable chinese tablet by trying what I did with my tablet.
Summary: Never Give Up
The key is to use the correct and suitable firmware for your tablet, though all the firmwares are built with Android OS but they may vary by brands and models. One firmware may be suitable for a tablet but may not be suitable for others. To look for the correct firmware, I recommend you to refer to your seller or product manufacturer, either by using their online website or by contacting their customer service personally.

Footnote: Resolving Malfunctioning Touch Screen Issue After Successful Flashing and Booting


In certain cases when you have successfully flashed the new firmware and made the android tablet boot normally again, but find out that the touch screen is not functioning and not reacting to any of user touch input, it is caused by a different touchscreen decoder chip you have in your tablet. To make it works for your tablet, you need to edit some of the firmware files. You can try this solution pointed out by one of our commenters ShibuVas:
For WM8650 models follow this to resolve touchscreen issue. There are many different versions of 8650 tablets using different touchscreen decoder chips - vt1603 or uor615x or uor615 or vt1609 or it7260 or others. The following example shows you how to modify the touchscreen decoder chip model in firmware files from vt1603 model to uor615x model. Make the following changes to files in the SD card prior to flashing:
  1. file FirmwareInstall/packages/fs_patch/root_patch/system/default.prop :
    find the line ro.wmt.touchpannel=0 and change it to ro.wmt.touchpannel=1
  2. file FirmwareInstall/env/uboot_env_head, for the 2 lines :
    setenv touchcodec vt1603 and setenv wmt.io.touch 1:vt1603:2:800:480
    change them to,
    setenv touchcodec uor615x and setenv wmt.io.touch 1:uor615x:0:800:480
Then flash the firmware as usual. If you have an 8" tab change all the '480's to '600's d( 800x600 resolution for a 8" tablet) - not applicable to your 7" case.
Currently documented touchscreen decoder chips are:
»   vt1603
»   vt1609
»   uor615x
»   uor615
»   it7260

Documented audio decoder chips are:
»   vt1603
»   wm8900

Please note if the touchscreen still does not work for you, i believe that you may have other touchscreen decoder chip type which we have not discussed here. I suggest you to ask your seller for the tablet specification especially the touchscreen decoder chip so you can alter the firmware files based on it.
Good luck, adios..

Reactions:

10 comments:

Way cool! Some very valid points! I appreciate you penning this post and the rest of the site is extremely good.


Also visit my page :: jocuri mario download gratis

Spot on with this write-up, I absolutely believe this website needs
a great deal more attention. IĆ­ll probably be
returning to read more, thanks for the information!


Feel free to visit my website - angry birds online spielen

Hi! I know this is kind of off topic but I was wondering if you knew where I could locate a captcha plugin for my comment form?
I'm using the same blog platform as yours and I'm having problems finding one?

Thanks a lot!

My web site ... using solar panels in spain

WOW just what I was looking for. Came here by searching for and
dvd-ram; video cd (vcd) and dvd-audio

My page :: video games

Hey There. I found your weblog the use of msn. That is a very well written article.
I will be sure to bookmark it and come back to learn extra of your helpful info.
Thank you for the post. I'll certainly return.

my page ... hd freeview receiver

An interesting discussion is definitely worth comment.
I do believe that you need to write more about
this subject matter, it might not be a taboo subject but generally
people do not speak about these issues. To the next!
All the best!!

my website: teeth whitening strips

I am satisfied that you simply shared this useful information with us.

It ranks each page on a website independently of one
another. You can even post their contributions on your home
page if you like. If you repeat the advice word-for-word, it's
taking credit for an idea that isn't yours.

my blog post hostgator discount coupon june 2014 ()

Your style is unique in comparison to other
folks I have read stuff from. Thank you for posting
when you've got the opportunity, Guess I'll just bookmark
this blog.

Here is my homepage ... game of war fire age mod

I really like it when folks get together and share opinions.
Great website, keep it up!

Post a Comment

Page Navigation Widget